Zenoss Installation Troubles

Today we were trying to install Zenoss - what appears to be a nice package. However, the installer tools don't appear ready for prime time.

  • Paths are hard coded
  • Only works with MySQL (no Firebird, Sqlite or PostgreSQL)
  • Documented Environmental Variables don't work as expected

There were a few other issues too (not executable files, permissions, etc) but nothing major here. Also, don't try any symlink trickery if you wanted to, for example, install to /opt/zenoss - won't happen.

Real down side is that Zenoss requires Python 2.4.4 and installs it's own copy in /usr/local/zenoss. So that makes the install take a while, but we're a Gentoo shop so we're used to that wait ;).

Then Zope

Then gettext

And freetype and libpng and pycrypto and rddtool and zlib and a bundle more.

After all this we've decided that what the world needs is at least one more monitoring piece of software. Something simpler, easier to install, easier to configure and easier to extend. So shortly we'll be releasing Custos - our take on the subject of system monitoring.