edoceo

svn: warning: cannot set LC_CTYPE locale

You may see these messages on some servers, reported LANG will likely be different (according to your environment)

svn: warning: cannot set LC_CTYPE locale
svn: warning: environment variable LANG is en_GB.UTF-8
svn: warning: please check that your locale name is correct

This is caused by not having the proper locales generated on your system.

Update the file /etc/locale.gen to include the locales you want to support. For example:

en_GB.UTF-8 UTF-8
en_US.UTF-8 UTF-8

Next run the program called locale-gen to rebuild the necessary files.

The envrionment may need to be updated as well, that is .bashrc or /etc/profile or similar.

On Gentoo check /etc/env.d/02locale, re-run env-update and then source /etc/profile.

Loading Comments from Disqus...